Sophos Notification: Delay in delivery of inbound emails for EU-West1

Incident
June 13, 8:11pm UTC

Sophos Notification: Delay in delivery of inbound emails for EU-West1

Status: closed
Start: June 13, 2:32pm UTC
End: June 13, 8:11pm UTC
Duration: 5 hours 39 minutes
Affected Components:
Sophos Components Central - Sophos Email Sophos Central Products Ireland (EU-West-1)
Update

June 13, 2:32pm UTC

June 13, 2:32pm UTC

Sophos Notification: Important information about Sophos Email, please check: https://soph.so/5F5SCg
Unsubscribe at https://sophoscentral.status.page

Resolved

June 13, 8:11pm UTC

June 13, 8:11pm UTC

Mail delivery should be back to normal in EU-WEST-1.