Sophos Notification: Delay of inbound mail delivery

Incident
June 20, 1:20pm UTC

Sophos Notification: Delay of inbound mail delivery

Status: closed
Start: June 20, 9:50am UTC
End: June 20, 1:20pm UTC
Duration: 3 hours 30 minutes
Affected Components:
Sophos Components Central - Sophos Email Sophos Central Products Ireland (EU-West-1)
Update

June 20, 9:50am UTC

June 20, 9:50am UTC

Sophos Notification: Important information about Sophos Email in the EU-West-1 region, please check: https://soph.so/Eo3iPv
Unsubscribe at https://sophoscentral.status.page

Resolved

June 20, 1:20pm UTC

June 20, 1:20pm UTC

Some customers in our EU-West-1 region may have experienced a delay of some emails of up to approximately 1 hour, 40 minutes for the delivery of inbound email during the hours of 9:50 am UTC to 1:20 pm UTC

Our Development Team has addressed the issue and email delivery has returned to normal.