Sophos Notification System - Sophos Email EU-West1 Outbound Delays

Incident
September 27, 9:30am UTC

Sophos Notification System - Sophos Email EU-West1 Outbound Delays

Status: closed
Start: September 27, 8:10am UTC
End: September 27, 9:30am UTC
Duration: 1 hour 20 minutes
Affected Components:
Sophos Components Central - Sophos Email Sophos Central Products Ireland (EU-West-1)
Update

September 27, 8:10am UTC

September 27, 8:10am UTC

Sophos Notification: Important information about Sophos Email, please check: https://soph.so/twsZ0k
Unsubscribe at https://sophoscentral.status.page

Resolved

September 27, 9:30am UTC

September 27, 9:30am UTC

Sophos Notification: Important information about Sophos Email, please check: https://soph.so/twsZ0k
Unsubscribe at https://sophoscentral.status.page