Sophos Notification:

Incident
April 23, 6:15pm UTC

Sophos Notification:

Status: closed
Start: April 23, 5:55pm UTC
End: April 23, 6:15pm UTC
Duration: 20 minutes
Affected Components:
Sophos Components Sophos Home
Affected Groups:
Grid Group
Update

April 23, 5:55pm UTC

April 23, 5:55pm UTC

We experienced an issue during backend systems maintenance that resulted in slowness or failure to load Sophos Home dashboards for approximately 20 minutes between 17:55 and 18:15 UTC. 

 Unsubscribe at https://status.sophos.com

Resolved

April 23, 6:15pm UTC

April 23, 6:15pm UTC

This issue has been resolved and all systems are operational.