Sophos Notification:

Incident
April 24, 4:13pm UTC

Sophos Notification:

Status: closed
Start: April 24, 2:24pm UTC
End: April 24, 4:13pm UTC
Duration: 1 hour 49 minutes
Affected Components:
Sophos Components Central - Sophos Email Ireland (EU-West-1)
Affected Groups:
Grid Group
Update

April 24, 2:24pm UTC

April 24, 2:24pm UTC

Important information about Sophos Email, please check: https://soph.so/9ThPB1
 Unsubscribe at https://status.sophos.com

Resolved

April 24, 4:13pm UTC

April 24, 4:13pm UTC

The incident has been resolved.