Sophos Notification:
Sophos Notification:
September 10, 2:14pm UTC
September 10, 2:14pm UTC
Important information about Sophos Switch, please check: https://soph.so/mgxq33
Unsubscribe at https://status.sophos.com
September 11, 9:34am UTC
September 11, 9:34am UTC
Investigation is still ongoing
September 11, 9:50am UTC
September 11, 9:50am UTC
Important information about Sophos Switch, please check: https://soph.so/mgxq33
Investigating. Unsubscribe at https://status.sophos.com
October 09, 8:55am UTC
October 09, 8:55am UTC
Resolved at 08:45 UTC on October 09, 2024. Please check: https://soph.so/mgxq33