Sophos Notification:

Scheduled
October 15, 10:00am UTC

Sophos Notification:

Status: closed
Start: October 15, 8:30am UTC
End: October 15, 10:00am UTC
Duration: 1 hour 30 minutes
Affected Components:
Sophos Components Central - Sophos Email Canada (CA-Central-1)
Affected Groups:
Grid Group
Update

October 15, 8:30am UTC

October 15, 8:30am UTC

Important information about the Sophos Email,  please check: https://soph.so/ttb11m
 Unsubscribe at https://status.sophos.com

Resolved

October 15, 10:00am UTC

October 15, 10:00am UTC

This maintenance is now complete.