Important Sophos Notification Regarding: Sophos Central

Scheduled
May 17, 7:10pm UTC

Important Sophos Notification Regarding: Sophos Central

Status: closed
Start: May 17, 1:00pm UTC
End: May 17, 7:10pm UTC
Duration: 6 hours 10 minutes
Affected Components:
Sophos Products and Services Central - Partner Dashboard Central - Admin Dashboard Central - Enterprise Dashboard Central - Self Service Portal Sophos Home Australia (AP-Southeast-1) Brazil (SA-East-1) Sophos Home Dashboard Sophos Home Support Portal Australia (AP-Southeast-1) Brazil (SA-East-1) Canada (CA-Central-1) Canada (CA-Central-1) Germany (EU-Central-1) Germany (EU-Central-1) India (AP-South-1) India (AP-South-1) Ireland (EU-West-1) Ireland (EU-West-1) Japan (AP-Northeast-1) Japan (AP-Northeast-1) Ohio (US-East-2) Ohio (US-East-2) Oregon (US-West-2) Oregon (US-West-2)
Affected Groups:
Grid Group
Update

May 17, 1:00pm UTC

May 17, 1:00pm UTC

Sophos Central Engineering will perform routine maintenance to Sophos Central on Saturday, May 17th, 2025, at 13:00 UTC,  lasting approximately 6 hours.

  • There will be no disruption to protected endpoints during this period.
  • The Sophos Status Page will reflect the maintenance status once it is started, as in progress, and when it is completed.

For further information and status updates, please review the following KBA.

Resolved

May 17, 7:10pm UTC

May 17, 7:10pm UTC

This maintenance has been completed