Important Sophos Notification Regarding: Sophos Central Email

Incident
June 02, 8:23pm UTC

Important Sophos Notification Regarding: Sophos Central Email

Status: closed
Start: June 02, 5:15pm UTC
End: June 02, 8:23pm UTC
Duration: 3 hours 8 minutes
Affected Components:
Sophos Products and Services Central - Sophos Email Germany (EU-Central-1) Ireland (EU-West-1) Ohio (US-East-2) Oregon (US-West-2)
Affected Groups:
Grid Group
Update

June 02, 5:15pm UTC

June 02, 5:15pm UTC

Inbound and Outbound emails are delayed due to Microsoft service degradation in Germany and North America.

For further information and status updates, please review the following KBA


Resolved

June 02, 8:23pm UTC

June 02, 8:23pm UTC

This issue has now been resolved